Base de coneixement
ADS Anàlisi/Disseny de Soft, S.L.U.
Buscar:     Búsqueda avanzada
Navegar por categorías:

No surt la meva impressora quan em conecto a traves de terminal server

Visitas: 1218
Posted: 15. June 2007
by:
Updated: 15. June 2007
by:
Las impresoras que utilizan puertos que no comienzan con COM, LPT o USB no se redirigen en una sesión de Escritorio remoto o Servicios de Terminal Server
Id. de artículo : 302361
Última revisión : jueves, 30 de diciembre de 2004
Versión : 4.3
Este artículo se publicó anteriormente con el número E302361
Síntomas
Cuando usa una sesión de Escritorio remoto o la versión de cliente 4.0 o 5.0 de Servicios de Terminal Server para conectar con otro equipo basado en Windows desde un equipo que no ejecuta Windows Server 2003, no se pueden redirigir las impresoras locales. En consecuencia, las impresoras locales no están disponibles en el escritorio remoto ni en la sesión de los Servicios de Terminal Server.

Por ejemplo, si el equipo basado en Windows XP tiene un dispositivo de impresión multifuncional que usa un puerto DOT4, no se puede redirigir en una sesión de escritorio remoto a un equipo basado en Windows 2000 o en Windows Server 2003.

Volver al principio

Causa
El problema se produce porque el puerto de impresora no empieza con COM, LPT o USB. De manera predeterminada, los nombres de puerto de impresora que no empiezan con COM, LPT o USB sólo se redirigen en Windows Server 2003. De manera predeterminada, los dispositivos de impresión multifuncionales no se pueden redirigir a menos que esté ejecutando Windows Server 2003 en el equipo local porque utilizan puertos DOT4.

Volver al principio

Solución
Para resolver este problema en un equipo que no ejecuta Windows Server 2003, fuerce a todos los puertos (incluido DOT4) del equipo cliente a que sean filtrados para redirección. Para ello, agregue un valor DWORD llamado FilterQueueType a HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR y configure su información de valor en FFFFFFFF.

Siga estos pasos y después salga del Editor del Registro:
1. Haga clic en Inicio, en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
2. Localice y, después, haga clic en la clave siguiente del Registro:
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR
3. En el menú Edición, seleccione Nuevo y haga clic en Valor DWORD.
4. Escriba FilterQueueType y, a continuación, presione ENTRAR.
5. En el menú Edición, haga clic en Modificar.
6. Escriba FFFFFFFF y, después, haga clic en Aceptar.
Esto permite que se redirijan todos los puertos del cliente.

Para evitar este problema en un equipo cliente que tenga un dispositivo de impresión multifuncional, cambie el puerto que usa ese dispositivo de DOT4 a un puerto LPT.

Por ejemplo, para configurar un dispositivo de impresión multifuncional para que use un puerto LPT en un equipo con Windows XP, siga estos pasos:
1. En Panel de control, abra Impresoras y faxes.
2. Haga clic con el botón secundario del mouse (ratón) en la impresora local no redirigida y, a continuación, haga clic en Propiedades.
3. Haga clic en la ficha Puertos, en un puerto LPT y en Aplicar.

La impresora debe aparecer ahora junto a ese puerto.
4. Cierre la ventana Propiedades de impresora y vuelva a conectar utilizando Escritorio remoto.
Importante
Cuando una impresora multifuncional usa un puerto LPT estándar en lugar del puerto DOT4, pierde las capacidades multifuncionales, como escáner, fax o copiadora. Para recuperar las capacidades multifuncionales, el dispositivo de impresora debe usar el puerto DOT4.

Volver al principio

Otras preguntas en esta categoría
» Más preguntas



RSS